Stay up to date

Developer changelog

API

Shopify will no longer support TLS 1.0 and 1.1

Effective June 20, 2018

Action required

Deprecation

As part of our commitment to providing a safe and secure platform, as of June 20, 2018, Shopify no longer support the outdated TLS 1.0 and 1.1 security protocols. Your apps will have to connect to our APIs using TLS 1.2.

This update is being made in accordance with new regulations set by the Payment Card Industry Data Security Standard (PCI). For more information, you can read the official statement from PCI on TLS 1.0.

You will need to test your apps to make sure they can connect to our APIs using TLS 1.2. If your app only supports TLS 1.0 or 1.1, then you will need to upgrade it to 1.2 by June 20, 2018.

If you have any questions about this change, then you can read our TLS documentation or contact apps@shopify.com.